Page Index Toggle Pages: 1 Send TopicPrint
Normal Topic File not saving correctly (Read 4642 times)
Jeff Hartman
Guest


File not saving correctly
Oct 11th, 2005 at 12:54pm
Print Post  
I have been using the XML viewer to successfully view my files.  I recently tried using it to add nodes and attributes.  Everything seems fine until I try to save the file.  It appears to save the file correctly, but the file then goes to 0 bytes in size and when I try to reopen it, all the data is gone.  I tried both Save and Save As with the same result.
  
Back to top
 
IP Logged
 
Jeff Hartman
Guest


Re: File not saving correctly
Reply #1 - Oct 11th, 2005 at 12:58pm
Print Post  
Sorry, this was meant to be posted on the XML Viewer bug reporter.  I see on that location that someone else already reported this same problem.

Jeff
  
Back to top
 
IP Logged
 
Meppy
God Member
*****
Offline


MindFusion support

Posts: 1783
Joined: Jul 20th, 2005
Re: File not saving correctly
Reply #2 - Oct 11th, 2005 at 2:35pm
Print Post  
Thank you too for sending me a file. I'll try to fix that tomorrow.
  
Back to top
 
IP Logged
 
Meppy
God Member
*****
Offline


MindFusion support

Posts: 1783
Joined: Jul 20th, 2005
Re: File not saving correctly
Reply #3 - Oct 12th, 2005 at 6:15am
Print Post  
The bug is fixed, you can get the patched exe from the link below:

http://nocache.mindfusion.org/XMLViewer.zip
  
Back to top
 
IP Logged
 
bkaga222
YaBB Newbies
*
Offline


I love YaBB 1G - SP1!

Posts: 1
Joined: Nov 21st, 2005
Re: File not saving correctly
Reply #4 - Nov 21st, 2005 at 8:09pm
Print Post  
Hello, the link with the fix posted here points to version 2.3, the issue with saving 0 byte files is ocurring in this version as well. Could you please post a new fix.
Thanks
  
Back to top
 
IP Logged
 
Meppy
God Member
*****
Offline


MindFusion support

Posts: 1783
Joined: Jul 20th, 2005
Re: File not saving correctly
Reply #5 - Nov 22nd, 2005 at 6:20am
Print Post  
Hi,

How did you manage to save a 0 byte file? I cannot reproduce that with the 2.3 version. Could you e-mail me a file that won't save correctly after loading and modifying it ?

Thank you
  
Back to top
 
IP Logged
 
Meppy
God Member
*****
Offline


MindFusion support

Posts: 1783
Joined: Jul 20th, 2005
Re: File not saving correctly
Reply #6 - Nov 23rd, 2005 at 11:24am
Print Post  
Thank you, indeed that happenned because of the '&' characters. This version should fix it:

http://nocache.mindfusion.org/XMLViewer.zip

Meppy
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint